using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"=['""]*\K[a-zA-Z0-9 ]+";
string input = @"name=MyName lastname='John Black' fathername='Bill Gen' age=30 ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}