$re = '/=[\'"]*\K[a-zA-Z0-9 ]+/im';
$str = 'name=MyName lastname=\'John Black\' fathername=\'Bill Gen\' age=30 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);