re = /=['"]*\K[a-zA-Z0-9 ]+/im
str = 'name=MyName lastname=\'John Black\' fathername=\'Bill Gen\' age=30 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end