package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https?:\/\/.*?(\/.*)`)
var str = `http://www.example.org/path/to/file.js?a12345678
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}