re = /https?:\/\/.*?(\/.*)/
str = 'http://www.example.org/path/to/file.js?a12345678
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end