$re = '/https?:\/\/.*?(\/.*)/';
$str = 'http://www.example.org/path/to/file.js?a12345678
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);