const regex = /(?<=\([:a-zA-Z0-9\s]*)}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\([:a-zA-Z0-9\\s]*)}', 'gm')
const str = `Accord}ing to Martin (1970: 59}, the job of someone who explains something to someone "is to fill in the gap between his audience's knowledge or beliefs about some phenomena and what he takes to be the actual state of affairs".`;
const subst = `)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);