use strict;
my $str = 'Accord}ing to Martin (1970: 59}, the job of someone who explains something to someone "is to fill in the gap between his audience\'s knowledge or beliefs about some phenomena and what he takes to be the actual state of affairs".';
my $regex = qr/(?<=\([:a-zA-Z0-9\s]*)}/mp;
my $subst = ')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";