import re
regex = re.compile(r"site[\s\S]{0,100}\/a>")
test_str = ("<body>\n"
"<!-- Websites navigation menu -->\n"
"<ul class=\"navbar\">\n"
"<li><a href=\"index.html\">Home page</a>\n"
"<li><a href=\"musings.html\">Musings</a>\n\n\n"
"In the following code, what is the regex (within Sublime's search) for finding \"site\" (seen within \"Websites\") and /a> (seen within ) only when there are between 0 and 50 characters of any type in between those two strings? I'd like to be able to perform searches like this on a regular basis, just changing out the two keywords and a distance, thanks.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")