#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ",(?=([^\"]*\"[^\"]*\")*(?![^\"]*\"))"
Local $sString = "impNutzer1;ImpNutzer1;ImpNutzer1Nach;impnutzer1@it.nrw.de;Y;null"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")