$re = ';,(?=([^\"]*\"[^\"]*\")*(?![^\"]*\"));';
$str = 'impNutzer1;ImpNutzer1;ImpNutzer1Nach;impnutzer1@it.nrw.de;Y;null';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);