const regex = new RegExp(',(?=([^\\"]*\\"[^\\"]*\\")*(?![^\\"]*\\"))', '')
const str = `impNutzer1;ImpNutzer1;ImpNutzer1Nach;impnutzer1@it.nrw.de;Y;null`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}