$re = '~^[\p{N}\p{L}\-+\.]{1,500}\.[\p{N}\p{L}][\p{L}-]*[\p{N}\p{L}]+$~um';
$str = 'google.com
masełkowski.pl
maselkowski.pl
m.maselkowski.pl
www.masełkowski.pl.com
xn--masekowski-d0b.pl
中国互联网络信息中心.中国
masełkowski.pl.
masełk..owski.pl
中国互联网络信息中心.xn--masekowski-d0b
api.aaaaaaaaaaaaaaaaaa34.23ab34bcde.343434343434343434.a1b2c3d4.urab.org
xxx
ayx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);