using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(?<number>\d{1,3}(?:\.\d{3})*(?:,\d+)?)€";
string input = @"Bruttosumme 9.943,90€
Bruttosumme 14.143,99€
Bruttosumme 543,99€
Bruttosumme 543€
Bruttosumme 14.543€
Bruttosumme 143.3,543€
Bruttosumme 143.321122344534,543€
Bruttosumme ,99€
Bruttosumme .14.543€
Bruttosumme .143.321122344534,543€";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}