$re = '/\s(?<number>\d{1,3}(?:\.\d{3})*(?:,\d+)?)€/';
$str = 'Bruttosumme 9.943,90€
Bruttosumme 14.143,99€
Bruttosumme 543,99€
Bruttosumme 543€
Bruttosumme 14.543€
Bruttosumme 143.3,543€
Bruttosumme 143.321122344534,543€
Bruttosumme ,99€
Bruttosumme .14.543€
Bruttosumme .143.321122344534,543€';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);