// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s(?<number>\d{1,3}(?:\.\d{3})*(?:,\d+)?)€").unwrap();
let string = "Bruttosumme 9.943,90€
Bruttosumme 14.143,99€
Bruttosumme 543,99€
Bruttosumme 543€
Bruttosumme 14.543€
Bruttosumme 143.3,543€
Bruttosumme 143.321122344534,543€
Bruttosumme ,99€
Bruttosumme .14.543€
Bruttosumme .143.321122344534,543€";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}