using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*[\w\-\+_]+(\.[\w\-\+_]+)*\@[\w\-\+_]+\.[\w\-\+_]+(\.[\w\-\+_]+)*\s*$";
string substitution = @"";
string input = @"g.g@asd.jfas.com.ua";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}