import re
regex = re.compile(r"^\s*[\w\-\+_]+(\.[\w\-\+_]+)*\@[\w\-\+_]+\.[\w\-\+_]+(\.[\w\-\+_]+)*\s*$")
test_str = "g.g@asd.jfas.com.ua"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)