#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?: *)(?P<all>(?P<first>[^\s]+)\s(?P<middle>de\s(?P<center>[^\s]+)\sde)\s(?P<last>.+).*)$"
Local $sString = " la de dah de dah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")