// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?: *)(?P<all>(?P<first>[^\s]+)\s(?P<middle>de\s(?P<center>[^\s]+)\sde)\s(?P<last>.+).*)$").unwrap();
let string = " la de dah de dah";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}