$re = '/^(?: *)(?P<all>(?P<first>[^\s]+)\s(?P<middle>de\s(?P<center>[^\s]+)\sde)\s(?P<last>.+).*)$/';
$str = ' la de dah de dah';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);