const regex = /<p>(<i>|<strong>)*<img\sclass="mceItem_breakpoint".*>(<\/i>|<\/strong>)?<\/p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>(<i>|<strong>)*<img\\sclass="mceItem_breakpoint".*>(<\\\/i>|<\\\/strong>)?<\\\/p>', 'g')
const str = `<p><img class="mceItem_breakpoint" src="></p>
<h4>Platzteller</h4>
<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>
<p><i><img class="mceItem_breakpoint" src="" /></i></p>
<p><strong><img class="mceItem_breakpoint" src=""></strong></p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}