# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p>(<i>|<strong>)*<img\sclass=\"mceItem_breakpoint\".*>(<\/i>|<\/strong>)?<\/p>"
test_str = ("<p><img class=\"mceItem_breakpoint\" src=\"></p>\n"
"<h4>Platzteller</h4>\n"
"<p>Der Platzteller, auf dem Vorspeisen- und Suppenteller rechts daneben</p>\n"
"<p><i><img class=\"mceItem_breakpoint\" src=\"\" /></i></p>\n"
"<p><strong><img class=\"mceItem_breakpoint\" src=\"\"></strong></p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.