package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),([^,]*)$`)
var str = `http://stackoverflow.com/questions/3829483/how-to-replace-last-occurrence-of-characters-in-a-string-using-javascript
DailyStats,jlaer;priatil;uido,DailyStatsAdm
AuditEvents,aorl;atil;le;mran;uido,AuditEventsAdm
`
var substitution = ";$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}