// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m),([^,]*)$").unwrap();
let string = "http://stackoverflow.com/questions/3829483/how-to-replace-last-occurrence-of-characters-in-a-string-using-javascript
DailyStats,jlaer;priatil;uido,DailyStatsAdm
AuditEvents,aorl;atil;le;mran;uido,AuditEventsAdm
";
let substitution = ";$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}