re = /,([^,]*)$/m
str = 'http://stackoverflow.com/questions/3829483/how-to-replace-last-occurrence-of-characters-in-a-string-using-javascript
DailyStats,jlaer;priatil;uido,DailyStatsAdm
AuditEvents,aorl;atil;le;mran;uido,AuditEventsAdm
'
subst = ';$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result