using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(UPDATE|INSERT\s).*?(?:\;)\n";
string input = @"INSERT ;
INSERT 1233;";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}