const regex = /^(UPDATE|INSERT\s).*?(?:\;)\n/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(UPDATE|INSERT\\s).*?(?:\\;)\\n', '')
const str = `INSERT ;
INSERT 1233;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}