package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^("[^"]*"|[^,]*), *("[^"]*"|[^,]*), *("[^"]*"|[^,]*), *("[^"]*"|[^,]*)$`)
var str = `cde, informative, "love coding, abcd,ab/cd", 0
abc, 12:30, love coding, re0*10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}