re = /^("[^"]*"|[^,]*), *("[^"]*"|[^,]*), *("[^"]*"|[^,]*), *("[^"]*"|[^,]*)$/m
str = 'cde, informative, "love coding, abcd,ab/cd", 0
abc, 12:30, love coding, re0*10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end