$re = '/^("[^"]*"|[^,]*), *("[^"]*"|[^,]*), *("[^"]*"|[^,]*), *("[^"]*"|[^,]*)$/m';
$str = 'cde, informative, "love coding, abcd,ab/cd", 0
abc, 12:30, love coding, re0*10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);