#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^6(?!011)(?:0[0-9]{14}|52[12][0-9]{12})$"
Local $sString = "6012345678901234" & @CRLF & _
"6521123456789012" & @CRLF & _
"6522123456789012" & @CRLF & _
"" & @CRLF & _
"60123456789012341" & @CRLF & _
"65211234567890122" & @CRLF & _
"65221234567890123" & @CRLF & _
"" & @CRLF & _
"6011221234567890" & @CRLF & _
"6522123456789012" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")