import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^6(?!011)(?:0[0-9]{14}|52[12][0-9]{12})$";
final String string = "6012345678901234\n"
+ "6521123456789012\n"
+ "6522123456789012\n\n"
+ "60123456789012341\n"
+ "65211234567890122\n"
+ "65221234567890123\n\n"
+ "6011221234567890\n"
+ "6522123456789012\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}