$re = '/^6(?!011)(?:0[0-9]{14}|52[12][0-9]{12})$/m';
$str = '6012345678901234
6521123456789012
6522123456789012
60123456789012341
65211234567890122
65221234567890123
6011221234567890
6522123456789012
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);