const regex = /^(?!www\.mysite\.com\/.*\/admin\.php).*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!www\\.mysite\\.com\\\/.*\\\/admin\\.php).*$', '')
const str = `www.mysite.com/*/admin.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}