$re = '/^(?!www\.mysite\.com\/.*\/admin\.php).*$/';
$str = 'www.mysite.com/*/admin.php';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);