re = /^(?!www\.mysite\.com\/.*\/admin\.php).*$/
str = 'www.mysite.com/*/admin.php'
# Print the match result
str.match(re) do |match|
puts match.to_s
end