const regex = /Level (300|[0-2]?\d?\d) ([^<]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Level (300|[0-2]?\\d?\\d) ([^<]*)', 'g')
const str = `<br />Level 163 Operative </div> <div class="sectionBar">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}