package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\[([\w .!?]+)\]|(\w+))`)
var str = `Code is fun [and good for the brain.] But the [brain is] tired.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}