re = /(?:\[([\w .!?]+)\]|(\w+))/
str = 'Code is fun [and good for the brain.] But the [brain is] tired.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end