$re = '/(?:\[([\w .!?]+)\]|(\w+))/';
$str = 'Code is fun [and good for the brain.] But the [brain is] tired.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);