re = /^(?:ALTER\ TABLE\ ONLY\ )
([^\n\r]+)[\n\r]
(?:ADD\ CONSTRAINT\ )
fk_\S+(?=.*REFERENCES\ ([^()]+))/mx
str = 'ALTER TABLE ONLY document_labels
ADD CONSTRAINT fk_g71qgs6l2ufr3170u44j5fpk3 FOREIGN KEY (label_id) REFERENCES application_value(id);
ALTER TABLE ONLY rule_group_functionality_mapping
ADD CONSTRAINT fk_g8twyunj9bm096sqywdi8rcx8 FOREIGN KEY (rule_group) REFERENCES application_value(id);
ALTER TABLE ONLY time_track
ADD CONSTRAINT fk_gmpyguqbpm1ndjjsxvt03wq4g FOREIGN KEY (user_id) REFERENCES user_account(user_id);
ALTER TABLE ONLY document_labels
ADD CONSTRAINT fk_document_labels_application_value FOREIGN KEY (label_id)
REFERENCES application_value(id);'
subst = 'ALTER TABLE $1\\nADD CONSTRAINT fk_$1_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result