package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d\.\d{2}$`)
var str = `1.23
0.12
21.21
1.2
3.1111
s.34
0dsj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}