import re
regex = re.compile(r"^\d\.\d{2}$", flags=re.MULTILINE)
test_str = ("1.23\n"
"0.12\n"
"21.21\n"
"1.2\n"
"3.1111\n"
"s.34\n"
"0dsj")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")