$re = '/^\s*{(\w+)}\s*=/';
$str = ' {blah_blah} = 2015-03-02;';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);