#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "test_function\((?!'[^'\\]*(?:\\.[^'\\]*)*'\))"
Local $sString = "test_function('something',true);" & @CRLF & _
"test_function('something',false);" & @CRLF & _
"test_function('something',true,true);" & @CRLF & _
"test_function(another_function('anotherthing',true),true);" & @CRLF & _
"" & @CRLF & _
"don't want to find this:" & @CRLF & _
"test_function('something');"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")