import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "test_function\\((?!'[^'\\\\]*(?:\\\\.[^'\\\\]*)*'\\))";
final String string = "test_function('something',true);\n"
+ "test_function('something',false);\n"
+ "test_function('something',true,true);\n"
+ "test_function(another_function('anotherthing',true),true);\n\n"
+ "don't want to find this:\n"
+ "test_function('something');";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}