import Foundation
let pattern = #"test_function\((?!'[^'\\]*(?:\\.[^'\\]*)*'\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test_function('something',true);
test_function('something',false);
test_function('something',true,true);
test_function(another_function('anotherthing',true),true);
don't want to find this:
test_function('something');
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)