using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Ваш заказ доступен по адресу:\s(?>\s*[а-яА-Я\w\d\,\.\!]+\s*\.?){1,5}(?<=\.\sЗабирайте скорее!)$";
string input = @"Ваш заказ доступен по адресу: dfdfdf dfdfdfdfdfdfdfdfdfdfd sfdnjв. Забирайте скорее!";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}