const regex = /Ваш заказ доступен по адресу:\s(?>\s*[а-яА-Я\w\d\,\.\!]+\s*\.?){1,5}(?<=\.\sЗабирайте скорее!)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Ваш заказ доступен по адресу:\\s(?>\\s*[а-яА-Я\\w\\d\\,\\.\\!]+\\s*\\.?){1,5}(?<=\\.\\sЗабирайте скорее!)$', '')
const str = `Ваш заказ доступен по адресу: dfdfdf dfdfdfdfdfdfdfdfdfdfd sfdnjв. Забирайте скорее!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}